Программирование на языке Java


Инструментальные средства JDK


Инструментальные средства JDK

appletviewer — программа просмотра апплетов Java

Доступность

JDK версии 1.0 и более поздних версий.

Синтаксис вызова

appletviewer [-debug] [-Japryмeнт] [-encoding кодировка] url/файл...

Описание

Программа appletviewer загружает один или несколько HTML-документов по указанным в командной строке URL. Она читает или загружает все апплеты, на которые содержатся ссылки в документах, и отображает каждый из них в собственном окне. Если ни один из названных документов не содержит тег <applet>, appletviewer не делает ничего.

Параметры

-debug

При указании данного параметра appletviewer запускается под управлением jdb (отладчик Java). Это позволяет отлаживать апплет, на который ссылается документ или документы.

-Jаргумент

Передает аргумент командной строки интерпретатору Java. Указанный аргумент не должен иметь пробелов. Если интерпретатору Java нужно передать аргумент, включающий в себя несколько слов, следует использовать соответствующее количество параметров -J. Список допустимых параметров интерпретатора Java можно найти в параграфе, посвященном описанию Java. Доступен в JDK версии 1.1 или более поздних версий.

-encoding кодировка

Определяет кодировку символов, которая должна использоваться программой appletviewer при чтении содержимого указанных файлов или URL. Он используется в процессе преобразования значений параметров апплета в Unicode. Доступен в JDK версии 1.1 или более поздних версий.

Команды

В окне программы appletviewer содержится единственное меню Applet со следующими командами:

Restart

Останавливает и уничтожает текущий апплет, затем заново инициализирует его и запускает повторно.

Reload

Останавливает, уничтожает и выгружает апплет, затем снова загружает, инициализирует и запускает его.

Stop

Останавливает текущий апплет. Доступна в JDK версии 1.1 или более поздних версий.

Save

Сериализует апплет и сохраняет его в файле Applet.ser в домашнем каталоге пользователя. Перед вызовом этой команды апплет необходимо остановить. Доступна в JDK версии 1.1 или более поздних версий.




- Начало -  - Назад -  - Вперед -